Forums


Issue Trying To Installing Up Passenger  

  RSS

doubledev
(@doubledev)
Member
Joined: 2 months ago
Posts: 2
29/01/2020 7:51 pm  

I am running into issues, most likely due to the fact this is a little older of a lesson, on trying to get passenger setup.  When I look to install a specific version of a gem, I found this:

INITIAL TRY:
sudo gem install rack passenger
ERROR: Error installing rack:
rack requires Ruby version >= 2.2.2.
ERROR: Error installing passenger:
rake requires Ruby version >= 2.2.

GETTING RACK INSTALLED:
sudo gem install rack -v 1.6
Successfully installed rack-1.6.0
1 gem installed

TRYING TO GET PASSENGER INSTALLED:

  1. sudo gem install passenger
    ERROR: Error installing passenger:
    rake requires Ruby version >= 2.2.
  2. sudo gem install passenger -v 4.0.56
    ERROR: Error installing passenger:
    rake requires Ruby version >= 2.2.
  3. sudo gem install passenger-4.0.56.gem
    ERROR: Could not find a valid gem 'passenger-4.0.56.gem' (>= 0) in any repository

Is there something different about this to get it installed?

Thank you


Quote
doubledev
(@doubledev)
Member
Joined: 2 months ago
Posts: 2
03/02/2020 2:46 pm  

Installed this rack version and continued on my way, from the git README file

sudo gem install rake --version 10.4.2


This post was modified 2 months ago 2 times by doubledev

ReplyQuote
Share:


  
Working

Please Login or Register